Welcome to the WRR/X Forum

A place to share your passion for the WR250R/X!
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  
WR250R/X Forum

Share | 
 

 Runs poorly- bogging under load, weak top end power HELP!!

View previous topic View next topic Go down 
AuthorMessage
jcmcc




PostSubject: Runs poorly- bogging under load, weak top end power HELP!!   Sat Feb 06, 2016 1:26 pm

Hey guys I'm hoping you can help me out with my 08 X as I'm at a loss of what to check for next.

It starts 100% and idles fine, however when you give the engine any load, it bogs and stumbles. It will eventually accelerate a bit, but has very weak top end power, and actually feels faster at part throttle rather than WOT.

As far as mods, it has AIS & exup removed (been off since I got it 3 years ago), K&N filter + deflappered, and an FMF fuel tuner. Also has a newer CA Cycleworks fuel pump installed a few months ago, and a Kreiger MCCT.

Here is the list of things I've tried thus far

Cleaned air filter
Removed fuel tuner- made very little difference
New Plug
New coil pack
Checked cam timing- good
Checked valves- good
Cleaned the fuel injector, checked for kinks in fuel hose- good
New Battery
Compression test- 85 psi, 120 with a little squirt of oil. Its a bit low but bike has 43k miles. Doubt that would cause a running problem like this anyway

I'm at a loss of what to look at next and I just wanna ride my bike again BOOM
Back to top Go down
wwguy

avatar


PostSubject: Re: Runs poorly- bogging under load, weak top end power HELP!!   Sat Feb 06, 2016 2:03 pm

Sounds like it's starving for fuel or air as demand increases. Just brainstorming some other ideas:
- Something wrong with the new fuel pump (because that's the last mod made to fuel system.) Maybe clogged fuel filter?
- Bad or old fuel. If not tried already this is cheap and easy to do.
- Clogged air filter (maybe too much oil?)
- FMF tuner not connected, working, or wrong fuel map. Not sure if previous map could be affected my new fuel pump or recently cleaned injector. But if it isn't working right you probably wouldn't see a difference by unplugging it.
- Clogged or bad fuel injector. FWIW the service manual recommends replacing, rather than cleaning. Replacement is around $120 last time I looked.

After that things get more expensive and/or complicated:
- Bad fuel pump
- Bad throttle body
- Bad ECU
Back to top Go down
Biglake




PostSubject: Re: Runs poorly- bogging under load, weak top end power HELP!!   Sun Feb 07, 2016 10:17 am

Im guessing low fuel pressure from a plugged filter or weak pump or a dirty injector.
Back to top Go down
MaggiesFarm




PostSubject: Re: Runs poorly- bogging under load, weak top end power HELP!!   Tue Feb 09, 2016 2:03 pm

I recently had a similar issue and I found out it was because the wires that plug into the clutch assembly had broken off.
Back to top Go down
jcmcc




PostSubject: Update   Sat Mar 05, 2016 1:08 pm

Well good news and bad news... I snapped the fuel pump hose nozzle on the pump after the tank dropped after I stepped away to grab a wrench:
http://imgur.com/a/prMX6

Can I replace that fitting or do I really have to buy a whole new pump?

The good news is that I'm confident I found my running problem. I replaced the ~4" section of plastic hose in the pump assembly with what I thought was fuel hose (got it from the parts dept at the dealer I work at) but I'm thinking it was heater hose due to how soft it is now. Fuel is definitely getting past each end of the hose.
Back to top Go down
Sponsored content




PostSubject: Re: Runs poorly- bogging under load, weak top end power HELP!!   

Back to top Go down
 
Runs poorly- bogging under load, weak top end power HELP!!
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Engine is missing / hesitating under load. Noticeable in 1,2,3 gears. Any ideas?
» Bad Bog at WOT
» YOUR SHITS WEAK UNLESS YOU HAVE VINYL
» Brampton's Best Youth BBall Runs
» 95 Riv Stutters under load Help

Permissions in this forum:You cannot reply to topics in this forum
Welcome to the WRR/X Forum :: General :: WRR/X General Discussion-
Jump to: