Welcome to the WRR/X Forum

A place to share your passion for the WR250R/X!
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  
WR250R/X Forum

Share | 
 

 My bike doesn't start

Go down 
AuthorMessage
hockey4ever




PostSubject: My bike doesn't start   Sat Jun 24, 2017 10:59 pm

My bike doesn't start anymore...  When i turn the key...  the dashboard light up.. but when I push the start button  nothing happen...   Please help.. I jumped start it with my car... no luck. .  wires at the battery are well connected..
Back to top Go down
dicklane625

avatar


PostSubject: Re: My bike doesn't start   Sun Jun 25, 2017 12:36 pm

The kill switch on the bars is in the on position?
Back to top Go down
Jens Eskildsen




PostSubject: Re: My bike doesn't start   Sun Jun 25, 2017 2:40 pm

Follow the wires from the killswitch, down to the right side of the frame, theres a connector there which can slightly disconnect itself.
Mine had a corroded wire there.
Back to top Go down
hockey4ever




PostSubject: Re: My bike doesn't start   Mon Jun 26, 2017 8:14 am

Exactly! that was this connector on the right side of the frame. I had to loosen the radiator to view and access this connector. Bike is up and running!! Very happy Big thank you for your help...
Back to top Go down
Sponsored content




PostSubject: Re: My bike doesn't start   

Back to top Go down
 
My bike doesn't start
Back to top 
Page 1 of 1
 Similar topics
-
» Cold start issue....Please HELP
» Belstaff Leather Bike Jacket + Lids
» Brisbane Track Class 11/02/11 Start Lists
» Trek Road Bike w/ Trainer - 58cm - Sold
» False start rule causes problems when applied sporadically

Permissions in this forum:You cannot reply to topics in this forum
Welcome to the WRR/X Forum :: General :: WRR/X General Discussion-
Jump to: