Welcome to the WRR/X Forum

A place to share your passion for the WR250R/X!
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  
WR250R/X Forum

Share | 
 

 intermittent run issue

View previous topic View next topic Go down 
AuthorMessage
greybeard2009




PostSubject: intermittent run issue   Thu Oct 05, 2017 10:41 pm

I have 2008 X model (13Kmi)with the usual mods, tuner, pipe, smog removed. I have ridden it for two years in true DS mode, single track, tarmac, fire roads, never a hiccup till this past spring. On a DS ride in SC the engine light came on, I shut bike off, checked oil and did a visual check of engine, tried to reatart and no go- checked connections at battery- saw no prob. Put all plastics back on and prepared to bump start it but tried start button and it fired. Did not think to check for codes. Rode on with light on 2? miles, killed engine- no start- no bump start. Sat until other riders insisted i let them push me to start- it fired again and I rode it back to the start/camp area- not going to push my luck. I had hauled it to this ride, when I got home I saw the 46 code, buy a new battery, fires up first try. Working out of state, I don't ride for 2 months, go to start and nada, 46 code after running bat down cranking, warranty out battery, new bat fires right up. I log about 200 more miles in DS mode then while riding close to home with my son he gets the engine light again, we head towards home but don't get a mile before it quits, this whole mile it was spitting and missing, no throttle position was good for it. Haul it home, charge bat, fires up next day. I ride solo another 60 miles one day and engine light comes on 5 miles from home, I make it home barely. Sometimes it will start, sometimes not. A day later it fires up. Then I remember the stator recall, test the running voltage and it is low, call local dealer and this VIN has not been fixed. Get new stator under warranty, bike fires right up which by now is not very reassuring. I had a ride planned the next day, I ride 3 miles one way to top off gas- no problem but not what I wanted for a shake-down run. I ride 3 miles to meeting point the next morning with no issues. We start for ride and it dies while idleing but refired pronto, we ride 2 miles and it quits when I hit clutch for a stop sign. It refires once but dies in 5 seconds so I just call home for a tow. It will start one time and not the next, sometimes it seems to start better when giving it gas, sometimes that just makes it backfire through exhaust. It may run 5 seconds if idle, it may run 3 minutes. It will usually run if you keep it around 4000 rpm, drop under that and instant stop. I checked reg/rec and it reads in spec using the diode setting on multimeter. I want to think I have always heard the pump humming, I know i have been checking that for the last few weeks it has had this issue. I suspect everything now, trust nothing. I plan to bypass the tuner to see if that has any effect. I don't know if the famous fuel pump issue is intermittent or not, thought it strange the stator was. I do much better with go or no-go issues, these intermittent ones are killing me. any suggestions, ideas, cures.
Thanks in advance!scratch
Back to top Go down
rsteiger

avatar


PostSubject: Re: intermittent run issue   Fri Oct 06, 2017 6:38 am

As far as the fuel pump issue goes it usually starts out as being intermittent - won't work after heating up.

You let the bike sit for awhile and things cool down then it will start again.
Back to top Go down
TwelveGaugeSage




PostSubject: Re: intermittent run issue   Fri Oct 06, 2017 12:08 pm

This may be a long shot, but next times it dies and doesn't want to start right away, open the fuel tank and see if it starts.
Back to top Go down
rsteiger

avatar


PostSubject: Re: intermittent run issue   Fri Oct 06, 2017 4:01 pm

^^^ +1 on this.

Seen the vent plugged before on other bikes which would not allow the bike to get fuel
Back to top Go down
greybeard2009




PostSubject: Re: intermittent run issue   Sat Oct 07, 2017 12:20 am

Thanks for the replies, after sitting all week, it won't fire today. Guess I will try a fleabay fuel pump.
Back to top Go down
johnkol




PostSubject: Re: intermittent run issue   Tue Oct 10, 2017 3:44 am

greybeard2009 wrote:
Thanks for the replies, after sitting all week, it won't fire today. Guess I will try a fleabay fuel pump.

Can you hear the pump priming when you turn the key? If yes, then the pump is probably not the problem.
Back to top Go down
greybeard2009




PostSubject: Re: intermittent run issue   Tue Oct 10, 2017 8:01 am

I can hear it humming anytime I turn key on, some here say that can be a false positive, and it still not work. I will st least have new filter, pump and plug while I have tank off.
Back to top Go down
johnkol




PostSubject: Re: intermittent run issue   Tue Oct 10, 2017 8:38 pm

greybeard2009 wrote:
I can hear it humming anytime I turn key on, some here say that can be a false positive, and it still not work. I will st least have new filter, pump and plug while I have tank off.

That's true, it can be a false positive, so the question is whether the humming sounds strong enough.

Have you seen this Yamaha-produced video? It has some steps where you can establish if the pump is working correctly:

Back to top Go down
greybeard2009




PostSubject: Re: intermittent run issue   Thu Oct 12, 2017 9:11 pm

Excellent video! very infomative. I got my new dfuel pump in today and it works. Bike started right up, didn't have time for a proper shake down but it ran two miles to the gas station and back. My next ride may be on more tarmac than dirt to verify long term but I am trusting it is good now. Pray
Back to top Go down
greybeard2009




PostSubject: Re: intermittent run issue   Wed Oct 18, 2017 2:28 pm

Just a little update, pump still works fine, have not had time for a long ride but each time I hit the button it has fired up not hesitation. So I am going to call it a fuel pump issue and be done. New stator, new fule pump, should be good for another 13K!
Thanks again for all the input!! Great site!!
Back to top Go down
Sponsored content




PostSubject: Re: intermittent run issue   

Back to top Go down
 
intermittent run issue
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Another poor soul with the intermittent stalling issue
» Low Coolant light, intermittent behavior?
» '95 SC Riviera Intermittent Stalling & Flashing PRND321
» Danica Patrick SI Swimsuit Issue
» September Issue of Mini World

Permissions in this forum:You cannot reply to topics in this forum
Welcome to the WRR/X Forum :: Technical :: What Broke?-
Jump to: