Welcome to the WRR/X Forum

A place to share your passion for the WR250R/X!
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  
WR250R/X Forum

Share | 
 

 Fuel pump?

Go down 
AuthorMessage
Greener73




PostSubject: Fuel pump?   Sun Jul 08, 2018 9:35 pm

Currently on a multi week trip across USA and Hoping to get confirmation that the fuel pump is the likely issue of my problem below.

I have a 2009 wr250r with about 40000kms.

About a week ago I was rolling into town with the fuel light on and the engine sputtered for a bit then died.it wasn’t out of fuel. I could hear the pump wine, and the bike would idle, but if I gave it any gas it would quit. THe whine on the pump sounded odd. I parked under a tree for half an hour, filled with fuel and it worked fine.

Fast forward and the same situation has happened about 5 more times. Now the tank doesn’t even have to be empty, it seems that if the engine is hot enough to make the rad fan run, I’m likely to have this issue.

I’m stuck in town waiting for a fuel pump.
I’m hoping you guys can confirm I’m fixing the right part. When I’ve read other posts it seems that their fuel pumps don’t turn on at all, however for me Every time the pump turns on when I turn the ignition, but the whine is odd. The sound is kind of like there is air in a line. When it runs correctly the whine is constant.

Am I on the right track? Could this problem be something else I’m overlooking?
Back to top Go down
 
Fuel pump?
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Welcome to the WRR/X Forum :: Technical :: General Maintenance Discussion-
Jump to: