Welcome to the WRR/X Forum

A place to share your passion for the WR250R/X!
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  
WR250R/X Forum

Share
 

 New bike, no lights...help please?

Go down 
AuthorMessage
lg22woo




New bike, no lights...help please? Empty
PostSubject: New bike, no lights...help please?   New bike, no lights...help please? EmptyTue Dec 11, 2018 8:07 pm

Hi all,

tl;dr: Only my rear light works on my new (to me) bike (no turn signals or headlight). Help please?

I just picked up a 2015 WRR with about 200mi on the odometer. Unfortunately, part of this great deal was that it came with none of the lights working. If anyone could give me a hand getting the lights back up and running again, that would be great! Here's what I know:

I opened it up for the first time and it had about 10 unterminated wires and maybe 4 unterminated connectors.

Rear:
It has a DRC Edge (not Edge 2) rear fender eliminator kit installed, but not wired. I was able to mess around with wires and got the rear light, license plate light, and brake light (brighter rear light on braking) working. I found the plugs for the rear turn signals, watched some videos to find which was which, and plugged them in. No response at all. The turn signals are brand new. I tried swapping the wires in case the previous owner had wired them backwards - still nothing.

Front
No headlight nor turn signals working. I took the headlight bulb out and it appears to be intact. I read 0.00 Volts on every wire on the headlight plug relative to ground, with the bike on and with high or low beams. The front has new integrated turn signals / hand guards. They already had the factory connectors attached to the signals and connected to the bike, but again, no sign of life.

There is also a 12oClockLabs fixed rate flasher module installed. I don't know if it works because I've never seen the turn signals work. Thank you in advance for any help!
Back to top Go down
YZEtc

YZEtc


New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyWed Dec 12, 2018 5:00 am

1) Do you have a Yamaha WR250R Service Manual (or, at least, the wiring schematic diagram)?

2) What were you told about the bike's history when you were in the process of buying the bike?
Back to top Go down
lg22woo




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyWed Dec 12, 2018 10:57 am

YZEtc wrote:
1) Do you have a Yamaha WR250R Service Manual (or, at least, the wiring schematic diagram)?

2) What were you told about the bike's history when you were in the process of buying the bike?

1) The bike came with no manuals. I found and downloaded a Owners Manual PDF online, but haven't found a service manual or wiring diagram yet. I think I found a 2008 WR250R service manual, but not sure how that differs from 2015 so I'm hesitant to use it.

2) The guy I bought it from was the second owner. The first owner had apparently crashed almost right after he bought it, cracking the front fairing and computer housing, and bending the stock handlebars and clutch lever. The computer still worked when the second owner purchased the bike with 149mi on it, but the computer was replaced to prevent water damage and the 2nd computer had 47mi on it when I bought it.
The second owner also installed a bunch of aftermarket things: foot pegs, skid plate, chain guard, rear fender eliminator kit w/ LED turn signals, hand guards with turn signals. He got the bike to ride offroad with a friend, and never ran it on the street, so didn't bother wiring turn signals and rear light (his words). I called him about the headlight yesterday - he said he had never seen it on, but never checked either because the two times he rode were during the day, offroad.
Back to top Go down
rsteiger

rsteiger


New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyWed Dec 12, 2018 1:45 pm

The 2008 Service Manual should work for what you need.

If you have doubts you can easily purchase one with out too much trouble.
Back to top Go down
YZEtc

YZEtc


New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyWed Dec 12, 2018 6:51 pm

I would check the easy and obvious things first (fuses, connections solid and not coming unplugged, etc.)

I'd get ahold of the wiring schematic diagram (the Yamaha Service Manual is worth it) and make sure all connections are correct and make sure no parts have gone missing.

If this is simply a case of the bike being crashed and the crasher just didn't put it back together properly, it can certainly be fixed.
I've bought more than one bike in that condition.
Back to top Go down
johnkol




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyWed Dec 12, 2018 7:27 pm

lg22woo wrote:
I opened it up for the first time and it had about 10 unterminated wires and maybe 4 unterminated connectors.

The unterminated wires are a red flag that the history of the bike is not as described to you by the previous owner.

In principle you could trace the wires through the schematic and make everything functional again, but this could take time and a lot of frustration, especially if you are not a very competent home mechanic.

Removing the entire wire loom and replacing it with a new one might be a very worthwhile alternative.
Back to top Go down
lg22woo




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyWed Dec 12, 2018 8:23 pm

johnkol wrote:
lg22woo wrote:
I opened it up for the first time and it had about 10 unterminated wires and maybe 4 unterminated connectors.

The unterminated wires are a red flag that the history of the bike is not as described to you by the previous owner.

In principle you could trace the wires through the schematic and make everything functional again, but this could take time and a lot of frustration, especially if you are not a very competent home mechanic.

Removing the entire wire loom and replacing it with a new one might be a very worthwhile alternative.

Agreed. Everything else on the bike looked to be in excellent condition, and everything I looked at was consistent with what the seller told me. I should have pulled the panels and seat and taken a look before buying, but at least I've learned my lesson now.

Also 100% agree on the time and frustration baldy That being said, I'm a mechanical engineer with a solid electrical background, so I have to at least try!

Looks like I should just go ahead and get a service manual. I'm sure I'll use it again in the future.

EDIT: Printed service manual is $90 on Yamaha's site!! tough Back to scouring the internet.

EDIT 2: Got a service manual PDF. The title page says "2008 WR250RX(C) WR250XX(C)". Not sure what that means, but hopefully it will still apply to my 2015 WR250R.
Back to top Go down
lg22woo




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyWed Dec 12, 2018 8:42 pm

This looks helpful! Where to start? dunno

New bike, no lights...help please? Screen10
New bike, no lights...help please? Screen11
Back to top Go down
lg22woo




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyWed Dec 12, 2018 8:54 pm

Nice! Troubleshooting flow chart.

New bike, no lights...help please? Screen12
Back to top Go down
JemmyOtis




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyWed Dec 12, 2018 11:13 pm

lg22woo wrote:
EDIT 2: Got a service manual PDF. The title page says "2008 WR250RX(C) WR250XX(C)". Not sure what that means, but hopefully it will still apply to my 2015 WR250R.

That manual should work fine, it's the same one I'm using for my 2017.
Back to top Go down
johnkol




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyThu Dec 13, 2018 3:28 am

lg22woo wrote:
That being said, I'm a mechanical engineer with a solid electrical background, so I have to at least try!

lg22woo wrote:
This looks helpful! Where to start? dunno

poser2  I don't know if you intended this as a joke, but it is hilarious! I'm an engineer myself, so I'm not laughing at you, I'm laughing with you.

The PDF manual you got is what a lot of people have, and it applies to all model years; the next page from the one you posted (page 364) has a colour-coded circuit so you can identify and follow all the wires.
Back to top Go down
lg22woo




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyThu Dec 13, 2018 10:31 am

johnkol wrote:


poser2  I don't know if you intended this as a joke, but it is hilarious! I'm an engineer myself, so I'm not laughing at you, I'm laughing with you.

The PDF manual you got is what a lot of people have, and it applies to all model years; the next page from the one you posted (page 364) has a colour-coded circuit so you can identify and follow all the wires.

Ha! I didn't mean it as a joke, but maybe I should have Very happy I guess we'll see how long it takes me to figure out these lights.

I saw color labels on the circuits (like "Y" for yellow), but my manual is all black and white. Do you have an actual colored diagram??
Back to top Go down
lg22woo




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyThu Dec 13, 2018 12:58 pm

johnkol wrote:

The PDF manual you got is what a lot of people have, and it applies to all model years; the next page from the one you posted (page 364) has a colour-coded circuit so you can identify and follow all the wires.

Ah, the very last page (364) is the color coded circuit! I didn't actually check the page number you sent originally, just assumed it was the one after what I posted, which was actually pg. 286 (8-15) in the lighting section. It's almost like Yamaha wrote this service manual for someone trying to troubleshoot a bike effectively! thumb

EDIT: For anyone following along with this thread, here's the nice color one:

New bike, no lights...help please? Screen13
New bike, no lights...help please? Screen14


Back to top Go down
johnkol




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptyFri Dec 14, 2018 6:16 pm

lg22woo wrote:
EDIT: For anyone following along with this thread, here's the nice color one

That's the one!

Good luck with troubleshooting, let us know how it goes.
Back to top Go down
lg22woo




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptySun Dec 16, 2018 8:01 pm

Almost there!

EDIT: Forgot to mention: a few days ago (between this post and the previous) I messed around with the rear wiring/connectors and got the tail light (low all the time, high when braking) and license plate light to work correctly.

Had some more time today, so I got the bike up on a stand and took all the plastics off. Went through the service manual lighting troubleshooting guide (pg. 288 aka 8-17) until I got to the fuse box. Pulled all the fuses and found BOTH 15 amp fuses were blown (one in the headlight slot, and the other in the spare slot). I guess previous owner somehow blew both fuses then was too lazy/cheap to change them?

Ok, whatever, easy fix! I put in a new fuse expecting everything to work and...no headlight. Tail light and license plate light still working the same as before. BUT now we have working turn signals....sort of! The turn signals were just on (solid light, not flashing). I took out the 12oClockLabs fixed rate flasher module and replaced it with the factory one. Now turn signals are working perfectly! I'm not sure why the 12oClockLabs module wasn't working right; to my knowledge, all lights except the headlight are now LEDs...but I don't really care why it doesn't work because the turn signals are fine now with the factory thingy. I'd say the signal lights flash about 2-3 times per second, which is acceptable.

Now to figure out why the headlight is not working at all. Following along with the troubleshooting guide...
1. The bulb looks ok and continuity checks on the terminals went as they should according to the service manual.
2. The fuses are all the correct size and intact now.
3. Battery reads 12.65 Volts and is powering everything else as expected.
4. Checking main switch...

New bike, no lights...help please? Img_8210
New bike, no lights...help please? Img_8211
New bike, no lights...help please? Img_8212


Last edited by lg22woo on Sun Dec 16, 2018 8:06 pm; edited 1 time in total
Back to top Go down
lg22woo




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptySun Dec 16, 2018 8:02 pm

New bike, no lights...help please? Img_8214
New bike, no lights...help please? Img_8213
New bike, no lights...help please? Img_8215
Back to top Go down
lg22woo




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptySun Dec 16, 2018 8:03 pm

New bike, no lights...help please? Img_8216
New bike, no lights...help please? Img_8217
New bike, no lights...help please? 20181210

Sorry for the triple post; apparently I can only upload 3 images at once?
Back to top Go down
johnkol




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptySun Dec 16, 2018 8:22 pm

lg22woo wrote:
I'd say the signal lights flash about 2-3 times per second, which is acceptable.

I think that is way too fast -- and that's the problem the 12 O'Clock flasher module is supposed to fix. Why don't you check with 12 O'Clock labs, they might have an easy procedure for checking whether the flasher is functioning or not.

lg22woo wrote:
Now to figure out why the headlight is not working at all.

Hopefully you know that the engine has to be running for the headlight to work?
Back to top Go down
lg22woo




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptySun Dec 16, 2018 8:27 pm

johnkol wrote:

Hopefully you know that the engine has to be running for the headlight to work?

cheers cheers cheers cheers cheers cheers cheers

I definitely knew that and was just testing you wink All lights working now, thanks everyone!
Back to top Go down
johnkol




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? EmptySun Dec 16, 2018 9:04 pm

lg22woo wrote:
I definitely knew that and was just testing you  wink All lights working now, thanks everyone!

poser2 Excellent come back!

I spent half a day troubleshooting the same "problem", the WRR is the first bike I have ever had with this feature (which I wish all bikes had).
Back to top Go down
Sponsored content




New bike, no lights...help please? Empty
PostSubject: Re: New bike, no lights...help please?   New bike, no lights...help please? Empty

Back to top Go down
 
New bike, no lights...help please?
Back to top 
Page 1 of 1
 Similar topics
-
» Belstaff Leather Bike Jacket + Lids
» HID lights
» Factory Steering rack & Tail lights
» Trek Road Bike w/ Trainer - 58cm - Sold
» ddm tuning hid lights any good ?

Permissions in this forum:You cannot reply to topics in this forum
Welcome to the WRR/X Forum :: Technical :: What Broke?-
Jump to: