Welcome to the WRR/X Forum

A place to share your passion for the WR250R/X!
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  
WR250R/X Forum

Share | 
 

 now ain't this odd

View previous topic View next topic Go down 
AuthorMessage
Toddwr250r

avatar


PostSubject: now ain't this odd   Thu Mar 17, 2011 2:32 pm

busted my R2 outa the shed today, to hang a new intergrated tail light before i dragged it off to the yami dealer to load my new rims and do a spring pm gave it a once over, did the air filter, oiled the chain up course i couldn't help but rip a couple of wheelies in the driveway thumb but i've got no horn!?!?! ya so i srtip er down and start poking around looking for something dumb, nothing showing outa place, horn works, when i feed it right out the bat, runs the fuel pump at the same time though scratch no power at the switch relay clicks when i jump to the horn it self, powered the switch and nothin scratch look at the fuses, the 10a that is labeled ing? ya it's popped! but it still starts and runs scratch scratch looks bridged, so i swap that out with the spare, still no horn? huh? guess i'll let the dealer look at it baldy anyone else had this one?
Back to top Go down
mash100

avatar


PostSubject: Re: now ain't this odd   Thu Mar 17, 2011 6:16 pm

Sounds weird, & I don't have much experience of this, BUT: I had a similar problem on my car some years ago. Some horns I believe are switched via the ground/negative side of the circuit, & NOT the positive side, as is normal for most other electrical stuff (lights etc.). So, might be worth checking this side of the things & have a look at wiring diagram....
Back to top Go down
RimBenty

avatar


PostSubject: Re: now ain't this odd   Thu Mar 17, 2011 10:59 pm

Mash is right, the wiring diagram shows the horn on the + side and the switch makes to the negative.

If you want a copy of the wiring diagram PM your email address to me and I'll send it to you.
Back to top Go down
andy mac




PostSubject: Re: now ain't this odd   Sat Mar 26, 2011 5:39 pm

My horn had died so yesterday I pulled the handlebar switch apart & cleaned all the dust out and cleaned the switch contacts. It works so reassemble it and it is now intermittent. Repeat. Pull apart 3rd time and now I notice there is some slack between the terminal & plastic housing. Pack this with a small piece of zip tie. Reassemble.

There are lots of small pieces in there so I pulled it apart over a 20 litre white drum to catch any dropped parts - there is a small spring and ball bearing under the red rocker switch. And laid them out in order for reassembly. 2 hours later the job was done. Beep Beep thumb I hope this is helpful to you.
Back to top Go down
Sponsored content




PostSubject: Re: now ain't this odd   

Back to top Go down
 
now ain't this odd
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Welcome to the WRR/X Forum :: Technical :: General Maintenance Discussion-
Jump to: