Welcome to the WRR/X Forum

A place to share your passion for the WR250R/X!
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  
WR250R/X Forum

Share | 
 

 Spedo off

View previous topic View next topic Go down 
AuthorMessage
ArrizX




PostSubject: Spedo off   Thu Apr 04, 2013 7:18 am

So I have an 08 WR250R bought it last year with 7500 miles on it. Love the bike, runs great, beat the hell out of it and it keeps going. But the spedo has always been off and I dont know why. Is it a tire size or a gear ratio thing? Because I know it reads off the rear tire.

Rear tire is a 4.10 and I havent count the sprocket. No idea if its stock or not. I do have an FMF power programmer and pipe on the bike, already installed, but I dont think that affects it.

Any help on what to do to make it read right? I do want to gear it down a little bit, what do I need to do then to make it read correctly? Right now it reads about 8mph fast. Thanks
Back to top Go down
motokid
Moderator
avatar


PostSubject: Re: Spedo off   Thu Apr 04, 2013 9:48 am

ArrizX wrote:
So I have an 08 WR250R bought it last year with 7500 miles on it. Love the bike, runs great, beat the hell out of it and it keeps going. But the spedo has always been off and I dont know why. Is it a tire size or a gear ratio thing? Because I know it reads off the rear tire.

Rear tire is a 4.10 and I havent count the sprocket. No idea if its stock or not. I do have an FMF power programmer and pipe on the bike, already installed, but I dont think that affects it.

Any help on what to do to make it read right? I do want to gear it down a little bit, what do I need to do then to make it read correctly? Right now it reads about 8mph fast. Thanks


Speedo is off roughly 7.7% straight from Yamaha.

If tires size changes on the rear - that'll make it off a bit more.

Gearing changes make it off too.

Pipe and programmer have nothing to do with it.


THANKS YAMAHA budah



If you want to make it right go to


http://www.12oclocklabs.com/ and buy the SpeedoDRD.

thumb

_________________
2008 WR250X
Gearing: 13t - 48t
Power Commander 5 / PC-V
Airbox Door Removed - Flapper glued - AIS removed
FmF Q4
Bridgestone Battlax BT-003rs
Back to top Go down
ArrizX




PostSubject: Re: Spedo off   Fri Apr 05, 2013 1:02 am

Hey thanks, just what I needed!!!
Back to top Go down
motokid
Moderator
avatar


PostSubject: Re: Spedo off   Fri Apr 05, 2013 9:48 am

Just be aware that changing what the speedo reads also changes the odometer.

For me it's much more important to know my speed than to know my exact distance traveled.

Speeding tickets are far more possible than anything having to do with odometer.


Just and FYI

_________________
2008 WR250X
Gearing: 13t - 48t
Power Commander 5 / PC-V
Airbox Door Removed - Flapper glued - AIS removed
FmF Q4
Bridgestone Battlax BT-003rs
Back to top Go down
ArrizX




PostSubject: Re: Spedo off   Fri Apr 05, 2013 11:02 pm

I figured because the speed was off there is also an improper odo reading. There are less miles on my bike because it thinks its going faster than it actually is, and it thinks its going more distance than it actually is, too
Back to top Go down
motokid
Moderator
avatar


PostSubject: Re: Spedo off   Sat Apr 06, 2013 1:55 am

In stock trim - the odometer is correct - it's just the the speedo that's 7.7% off.


_________________
2008 WR250X
Gearing: 13t - 48t
Power Commander 5 / PC-V
Airbox Door Removed - Flapper glued - AIS removed
FmF Q4
Bridgestone Battlax BT-003rs
Back to top Go down
ArrizX




PostSubject: Re: Spedo off   Sat Apr 06, 2013 6:39 am

I find that extremely irritating
Back to top Go down
YZEtc

avatar


PostSubject: Re: Spedo off   Sat Apr 06, 2013 11:23 am

Speedometer being off on a brand-new motorcycle = nothing new to me.
Even cable-driven ones off the front wheel read faster than actual speed.

Ever since electronics in droves made their way on to street-legal motorcycles, all of the factories have been using designs where a sensor used to collect data for onboard electronics can also be used for the speedometer pickup.
The first Yamaha I remember with this was the 1998 YZF-R1K.

Any bike with a speed sensor driven off the transmission will be effected by changing sprockets as far as the speedometer reading goes.
Back to top Go down
ArrizX




PostSubject: Re: Spedo off   Sun Apr 07, 2013 6:39 pm

Interesting.

I think mine is off more than 7.7% That would mean at 100mph its showing about 108.

Well at 30mph I have an 8mph difference and it my bike shows 38mph at an actual speed of 30mph. Something else isnt stock on my bike. Not sure what though. Rear tire is a 4.10 and I will need to count my teeth on the sprocket next time I go outside!
Back to top Go down
bigg

avatar


PostSubject: Re: Spedo off   Sun Apr 07, 2013 7:41 pm

Definitely count your teeth. Should be 13/43 in stock form for the R. I don't think a different sized tire would make such a huge difference (more than 20% off if it's indicating 38 at 30 mph, instead of the 7-8% off stock)
Back to top Go down
ArrizX




PostSubject: Re: Spedo off   Sun Apr 07, 2013 7:48 pm

I counted 44, but Im pretty sure I counted the one I started with so I would say I have the stock 43 in the rear. Its raining outside I dont want to go count the front. But I would venture to say its stock. I bought the bike with 7500 miles with 50/50 tires on it . It didnt look like it had EVER been ofroad. But the handles were cut down and filed which is an off road thing so I am not sure. I bought it from consignment at a dealership. But there wasnt a scratch or boot mark on it anywhere so I think it was just a bone stock thing. Had the pipe and programmer when I got it and it was set for mileage.

What else would account for the weird spedo rating?
Back to top Go down
bigg

avatar


PostSubject: Re: Spedo off   Tue Apr 09, 2013 5:53 pm

ArrizX wrote:
I counted 44, but Im pretty sure I counted the one I started with so I would say I have the stock 43 in the rear. Its raining outside I dont want to go count the front. But I would venture to say its stock. I bought the bike with 7500 miles with 50/50 tires on it . It didnt look like it had EVER been ofroad. But the handles were cut down and filed which is an off road thing so I am not sure. I bought it from consignment at a dealership. But there wasnt a scratch or boot mark on it anywhere so I think it was just a bone stock thing. Had the pipe and programmer when I got it and it was set for mileage.

What else would account for the weird spedo rating?

if the gearing is stock, it could be an electrical issue. a couple members here had issues with their speedo reading 3x the actual speed after the battery had gone completely flat / broke. any chance something similar has happened to your bike?

the interesting thing though is that in all the cases (although it's only been a few), the speedo read 3x the speed, not ~25% like yours.

anyway, have a read through here http://wr250rforum.forumotion.com/t5263-speedo-reading-3x-actual-speed-after-batter-change
maybe something similar happened to you? Just taking wild guesses here dunno
Back to top Go down
IAmABug




PostSubject: Re: Spedo off   Tue Apr 09, 2013 6:42 pm

Check the front sprocket as well. 13 is stock. I went to 12/47 gearing which put my bike off 22.6%. Maybe you have a 12T in the front?
Back to top Go down
ArrizX




PostSubject: Re: Spedo off   Wed Apr 10, 2013 6:10 am

Interesting. Thanks for the replies and I will check into the front sprocket. I didnt think it was worth mentioning but ill tell you guys that yes I did let the battery die completely once, compression started it and its been good since.

Also, about a week after I got the bike someone stole my keys. I live in a small town, and leave my keys in everything and everything unlocked. Anyways I went to the hardware store and someone took the key out of it for me. I was going to replace it but it was faster to pull it apart and toggle switch it. The bike at first start looks normal, and then you put it in neutral to start it with the stand down and the neutral light never goes off.

I dont think either is worth mentioning though because the bike as done it from day 1 when I bought it. I noticed it on the test ride that it was way fast.
Back to top Go down
motokid
Moderator
avatar


PostSubject: Re: Spedo off   Wed Apr 10, 2013 10:51 am

I think a few people who've had batteries go completely dead have reported massive issues with speedometers going bat-shit crazy.

Let me see if I can find that thread....

edit: here's the one I was thinking of: click me

and the other one: clickity me too

_________________
2008 WR250X
Gearing: 13t - 48t
Power Commander 5 / PC-V
Airbox Door Removed - Flapper glued - AIS removed
FmF Q4
Bridgestone Battlax BT-003rs
Back to top Go down
ArrizX




PostSubject: Re: Spedo off   Thu Apr 11, 2013 6:54 am

Thanks for the links. I feel like I am just SOL and I need to deal with it!!
Back to top Go down
motokid
Moderator
avatar


PostSubject: Re: Spedo off   Thu Apr 11, 2013 9:46 am

ArrizX wrote:
Thanks for the links. I feel like I am just SOL and I need to deal with it!!

Do an odometer check.

See if that's way off as well.


_________________
2008 WR250X
Gearing: 13t - 48t
Power Commander 5 / PC-V
Airbox Door Removed - Flapper glued - AIS removed
FmF Q4
Bridgestone Battlax BT-003rs
Back to top Go down
tick-tock




PostSubject: Re: Spedo off   Tue Apr 16, 2013 4:23 pm

I'm experiencing the same issue with mine; way off. It also seems to get progressively worse. At a true 35mph, the speedo reads 41 but at a true 48mph, the speedo reads 61. That's with stock gearing and tires.
Back to top Go down
Sponsored content




PostSubject: Re: Spedo off   

Back to top Go down
 
Spedo off
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Welcome to the WRR/X Forum :: Technical :: General Maintenance Discussion-
Jump to: